Performance Issues

Incident Report for Vagaro

Resolved

This incident has been resolved. We apologize for any inconvenience this may cause and thank you for your patience and understanding.
Posted Feb 19, 2026 - 11:51 PST

Investigating

Our development team is still actively working to resolve the current slowdown/service interruption some Vagaro customers are experiencing. We thank you for your patience and we apologize for any inconvenience.
Posted Feb 19, 2026 - 10:16 PST
This incident affected: Vagaro.com and Vagaro Pro App.