Performance Issues

Incident Report for Vagaro

Resolved

This incident has been resolved. We apologize for any inconvenience this may cause and thank you for your patience and understanding.
Posted Oct 29, 2025 - 11:15 PDT

Update

Our team is diligently working to resolve this issue as soon as possible. We apologize for any inconvenience.
Posted Oct 29, 2025 - 10:44 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 09:37 PDT

Identified

Some Vagaro customers are currently experiencing a slowdown resulting from a Microsoft Azure interruption. Our development team is actively working to resolve this issue as soon as possible. We apologize for any inconvenience.
Posted Oct 29, 2025 - 09:34 PDT
This incident affected: Vagaro.com and Vagaro Pro App.