Vagaro Customer Support Phones are Down

Incident Report for Vagaro

Resolved

The incident is now resolved.
Posted Jan 22, 2025 - 17:20 PST

Update

We are still waiting for a resolution from our telecommunications provider.

In the interim, please contact support via:

Chat: https://support.vagaro.com/
Email: support@vagaro.com

We apologize for any inconvenience this may cause and will provide updates as they become available.
Posted Jan 22, 2025 - 14:43 PST

Investigating

Due to a technical issue with our telecommunications provider, some Vagaro customers may experience difficulty reaching our Customer Support team by phone. We are actively working with our provider to resolve this issue.

In the interim, please contact support via:

Chat: https://support.vagaro.com/
Email: support@vagaro.com

We apologize for any inconvenience this may cause and will provide updates as they become available.
Posted Jan 22, 2025 - 12:08 PST
This incident affected: Vagaro Phone Support.