Credit Card Processing Issue
Incident Report for Vagaro Inc
Resolved
We have located the issue with processing credit cards and have resolved it.
Posted over 1 year ago. Jun 02, 2017 - 12:20 PDT
Investigating
Currently investigating intermittent issues with processing credit cards with Vagaro Merchant Services.
Posted over 1 year ago. Jun 02, 2017 - 12:06 PDT