Intermittent Merchant Services Issues
Incident Report for Vagaro Inc
Resolved
The issue has been resolved.
Posted 7 months ago. Sep 21, 2018 - 05:45 PDT
Investigating
We have received a few complaints regarding merchant services giving an error. Our development team is looking into the issue to resolve it as quickly as possible.
Posted 7 months ago. Sep 21, 2018 - 04:19 PDT
This incident affected: Credit Card Processing.