Vagaro Web Slowdown
Incident Report for Vagaro Inc
Resolved
The slowdown issues have normalized and are no longer impacting our services.
Posted May 17, 2022 - 15:13 PDT
Investigating
We recently detected some latency issues for customers in the Eastern US, when accessing the web version of Vagaro. Our team is working to resolve the issue. Thank you for your patience.
Posted May 17, 2022 - 13:09 PDT
This incident affected: Vagaro.com.