Slow Down
Incident Report for Vagaro Inc
Resolved
Everything is resolved and back to normal. Thank you for your patience.
Posted 9 months ago. Aug 01, 2018 - 12:39 PDT
Investigating
We are currently experiencing a Slow Down with some connections via the website version of Vagaro. If possible download Vagaro Pro app for your phone or tablet while we are resolving this issue.
Posted 9 months ago. Aug 01, 2018 - 12:09 PDT
This incident affected: Vagaro.com.