Credit Card Processing Issue
Incident Report for Vagaro Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jun 20, 2017 - 14:42 PDT
Investigating
We are looking into an issue that is causing intermittent issues with Vagaro Merchant Services
Posted almost 2 years ago. Jun 20, 2017 - 14:07 PDT