Credit Card Processing Issue
Incident Report for Vagaro Inc
Resolved
We have located the issue with credit card processing and resolved it.
Posted almost 2 years ago. Jun 09, 2017 - 15:19 PDT
Investigating
We are looking into an issue that is causing intermittent issues with processing credit cards.
Posted almost 2 years ago. Jun 09, 2017 - 15:00 PDT