Merchant Processing
Incident Report for Vagaro Inc
Resolved
Our development team has resolved the issue with merchant services.
Posted over 1 year ago. Feb 13, 2018 - 11:39 PST
Investigating
We currently investigating an issue that is preventing users from processing credit cards. Our engineering team is on and we expect to resolve it shortly.
Posted over 1 year ago. Feb 13, 2018 - 10:10 PST