Slowdown Impacting Customers in the Eastern US Region
Resolved
This incident has been resolved. We apologize for any inconvenience this may cause and thank you for your patience and understanding.
Posted Aug 15, 2025 - 10:02 PDT
Investigating
Some Vagaro customers in the Eastern US region are currently experiencing a slowdown/service interruption.. Our team is actively working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Aug 15, 2025 - 09:20 PDT
This incident affected: Vagaro.com and Vagaro Pro App.